Announcement

Collapse
No announcement yet.

End Links Rubbing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • End Links Rubbing

    Hi Guys,

    Thought I would post this here to try out the new forum and also because it is an IPD product.

    I have some IPD HD Front End links I installed back in October 2019 or so. I didn't notice any issues with them, but after changing out my front struts I noticed there had been some contact between the end links and the frame.

    I painted over the area, and thought maybe all my new suspension pieces would magically fix the issue (LCA+struts+mounts). Well they didn't, and I can still hear a clunking noise from the passenger (right) side of the car. The driver side seems ok, no evidence of rubbing.

    I do notice the IPD HD end links are a bit wider at the back (where the rubbing is occurring) compared to the old unknown ones I took off the car.


    Click image for larger version

Name:	endlink.png
Views:	78
Size:	10.59 MB
ID:	3182

    Click image for larger version

Name:	IMG_20200803_161816.jpg
Views:	65
Size:	1.93 MB
ID:	3181
    Attached Files

  • #2
    I ended up removing the IPD HD end links and installing the OEM ones as they were still OK.

    I re-painted the scratched area to see if the OEM ones scratch as well, but so far they are ok.

    I think perhaps with the strut spacer on the AWD model that the end links sit too low and rub. They are slightly larger than the OEM ones (thickness between strut and back of end link).

    Click image for larger version

Name:	IMG_20200805_162541.jpg
Views:	75
Size:	622.6 KB
ID:	3210
    Attached Files

    Comment

    Working...
    X